BizTalk Server 2020: Hardware and Software

 

Introduction

In this article we will understand the details of hardware and software requirement for installing BizTalk Server 2020. Before we install BizTalk Server 2020, there are some prerequisites that we need to check, because without these prerequisites we might face issue in future or our BizTalk Server will not work as expected. So to avoid such behavior, we have to configure the BizTalk server accordignly. Let’s see what are the basis mandatory or optional Hardware and Software requirement we have here,

Hardware Requirements

Computer and processor:

  • 1.4 GHz or higher for single processors
  • Intel Pentium-compatible CPU, Not supported on Itanium-based systems
  • Hyper-threading and multi-core processors are supported — BizTalk Server 64-bit requires a 64-bit operating system running on an x64-based machine. x64-based systems are those that use CPUs that are compatible with the AMD64 (x86-64) and Extended Memory 64-bit Technology (EM64T) processor architectures.

Memory: 4 GB or more

Hard Disk: 10 GB of Hard Disk (NTFS formatted)

Hardware and Software Requirements

Software Requirements Required for BizTalk Component
Microsoft Windows
Windows Server 2019, Windows Server 2016, Windows 10
Mandatory for all BizTalk Component
Internet Information Services
IIS is included with the Windows operating system EDI, BAM, Management REST API, and the SharePoint adapter
Windows Identity Foundation
Used in the Windows SharePoint Services
Optional
Microsoft SharePoint
SharePoint Services 2019, SharePoint Services 2016, SharePoint Services Online
Optional, and required in SharePoint Services
Microsoft Office
Microsoft Office Excel 2019, Microsoft Office Excel 2016 Optional, and required in BAM
Microsoft .NET Framework
.NET Framework 4.7.2 minimum Mandatory for all BizTalk Server managed Component
Microsoft Visual Studio
Visual Studio 2019 (Version 16.4.0)
Optional, and required for BizTalk Server Developer Tools and SDK
Microsoft Visual C++ 2015-2019 Redistributable Package
The x86 and x64 versions are required
Mandatory
Microsoft OLE DB Driver for SQL Server
Microsoft OLE DB Driver 18.3.0 for SQL Server Mandatory for all BizTalk Server devices
Microsoft SQL Server
Microsoft SQL Server 2019, Microsoft SQL Server 2017, Microsoft SQL Server 2016 SP2 CU7 Mandatory
SSIS Catalog
  Optional, and required to use BAM
SQL Server Database Mail
  Optional, and required to use BAM alert
SQL Server Analysis Services ADOMD.NET
SQL Server 2016 Analysis Services ADOMD.NET Optional, and required to use BAM alert
WinSCP
WinSCP version 5.15.4 Mandatory for SFTP adapter
MQSeries adapter
IBM WebSphere MQ 8, IBM WebSphere MQ 9 Optional, and required in IBM WebSphere MQ
LOB and enterprise systems
  Mandatory for adapters in the BizTalk Adapter Pack

References

The following table lists the minimum Hardware and Software requirements for our BizTalk Server computer. In a production environment, the volume of traffic may require greater hardware requirements for our servers.

Microsoft Doc Ref Click here
BizTalk Techie Click here

Read Also

You can also read below artciles to understand BizTalk Server 2020 new release along with Hardware and Software requirement in BizTalk Server

Leave a Reply

Your email address will not be published.